VW Vento Knocking & EPS Getting Engaged


Thread Starter #1
Joined
Aug 15, 2019
Messages
4
Likes
1
Location
Mumbai/Pune
Hi friends, am new here. I'm facing an engine knocking issue in my vento tsi for the past 6-7 months may be 10k kms. When I accelerate normally it works fine but when I need higher acceleration, it knocks and doesn't gain quick speed, sometimes so much so that it engages esp feature (eps and epc lights glow on odometer) and car starts vibrating, then when I turn the car off and turn it again, it becomes normal. I've done 75k kms in 4 yrs. Have no other complaint from vento, its been a dream car (done max 185kmph when new), and served me well (75k kms). Off late started facing this issue. Can anyone help understand what could be the issue. Its going for 75k kms periodic maintenance next week. Have been getting servicing done at every 15k kms. I have high highway usage and approx 20-25k km usage per year.
 

allhyundaicars

Honoured Member
Joined
Apr 21, 2012
Messages
7,445
Likes
3,026
Location
New Delhi
I think it could be the infamous injector issue. Many vento owners had to replace the injectors. Is your car under warranty ? Did you report this knocking issue to the sc ?

Also some say that calibration of the injectors solve the problem. Check this video.
 
Last edited:
Thread Starter #3
Joined
Aug 15, 2019
Messages
4
Likes
1
Location
Mumbai/Pune
I think it could be the infamous injector issue. Many vento owners had to replace the injectors. Is your car under warranty ? Did you report this knocking issue to the sc ?

Also some say that calibration of the injectors solve the problem. Check this video.
thanks. No, car is not under warranty as I had not taken extended warranty thinking nothing can happen to a vw, but it's a lesson and will always take it going forward. I did not report it to sc thinking it could be a oil or air filter problem which they can fix during my periodic maintenance visit which is scheduled next week. I googled yesterday and realized that it could be an injector issue and I should brace myself for shelling out lot of money now (some posts suggested it could well run over a lac)

Your observation also makes it almost certain that it could be the case. Thanks for your inputs and video link, I don't think ill be able to do it myself as I'm not a pro or amateur in this field, now at mercy of sc
 

allhyundaicars

Honoured Member
Joined
Apr 21, 2012
Messages
7,445
Likes
3,026
Location
New Delhi
Do update what the sc has to say. Don't tell them anything about the video just let them diagnose it and if they say injector needs replacement ask them which one and then tell them what's this calibration is about.
 
Joined
Oct 14, 2016
Messages
304
Likes
339
Location
Erode
I had the same issue on my Vento Tsi at 35000 KM's at 12 months of ownership.I sold the car after failing to get a solution from dealer though I had extended warranty. The dealer kept saying everything was fine. Sold after 13 months and 42k on the odo. Good bye Folkswagen!
 
Thread Starter #6
Joined
Aug 15, 2019
Messages
4
Likes
1
Location
Mumbai/Pune
Do update what the sc has to say. Don't tell them anything about the video just let them diagnose it and if they say injector needs replacement ask them which one and then tell them what's this calibration is about.
sc informed that knocking is due to sulphur which has come in, in the automatic transmission (may be because water went inside due to washing of engine area) and current is not getting produced properly. They have cleaned the sulphur for now but they said that while knocking has reduced but it has not gone completely. They have further informed that they will need to replace ignition coil, cord and transformer in the engine's automation transmission system costing 18k.
 

allhyundaicars

Honoured Member
Joined
Apr 21, 2012
Messages
7,445
Likes
3,026
Location
New Delhi
I am not sure how you should go further , many a times service centre replaces a part they think needs replacing. Even after that problem persists sometime and they say the changed part needed to be changed and now we will look for other part problem.

I searched on google you should do a thorough reading how to solve this issue. Looks like a gearbox problem.
sulphur inside automatic tranmisiion vw - Google Search
 
Thread Starter #8
Joined
Aug 15, 2019
Messages
4
Likes
1
Location
Mumbai/Pune
Thanks a lot for your inputs. I will update later if parts change worked. They don't have parts now and will order so ill go there after couple of weeks
I had the same issue on my Vento Tsi at 35000 KM's at 12 months of ownership.I sold the car after failing to get a solution from dealer though I had extended warranty. The dealer kept saying everything was fine. Sold after 13 months and 42k on the odo. Good bye Folkswagen!
that's quite a bad experience!
 
Top Bottom