Turn Indicator Not Blinking


Thread Starter #1
Joined
Sep 21, 2009
Messages
24
Likes
0
Location
Trichy
My car's(Swift VXi) right side turn indicators are malfunctioning. When i turn on the right side indicator, all the three bulbs are just glowing continously (i.e.) not blinking and if i take the key out also the bulbs remain glowing. But the left side indicators are working good. I took the car to my dealer's workshop, the mechanic was not able to solve the problem. The malfunctioning continues. [lol]
 
Joined
Sep 6, 2009
Messages
1,025
Likes
20
Location
Pune
Somethings wrong with the wire's or electrical.Must have happened due to rain's rat biting etc.How come the dealer is not able to solve the problem ? Take it to some other Service Station.
 

350Z

Core Team
Joined
Aug 10, 2009
Messages
18,428
Likes
6,205
Location
New Delhi
Welcome aboard to The Automotive India. It might be an issue with the flasher fuse. Get it checked or replaced from an authorized Maruti Workshop.

Drive Safe!
350Z
 
Joined
Aug 24, 2009
Messages
1,055
Likes
15
Location
Bangalore
Yes, it could be an issue either with the fuse (located below the dash board - driver side) or is a problem with the relay circuit for the blinkers. Nothing to worry! Just get this checked at a better electric work shop.
 
Joined
Sep 16, 2009
Messages
270
Likes
13
Location
Calicut/Coimbatore
The same problem has caused to me last year but after replacing the indicator flasher it started working properly.In my opinion the problem might be caused because of the fuse or the wiring if none of these worked out try replacing the FLASHER UNIT.

Karthik.
 
Last edited:
Joined
Sep 7, 2009
Messages
482
Likes
3
Location
Trivandrum
How come the left indicators work perfectly when the flasher is kaput or because of blown fuse?[confused]

And even if he removes his his key, the light keep on glowing. So does it have something to do with flasher?
 

napster

Suspended
Joined
Aug 23, 2009
Messages
545
Likes
8
Location
AP-09
im having the same problem with my m800, the left indicator works fine but the right indicators blink very fast, my front indicator below the head lamps wasnt working and from that day im having this problem, i checked the bunk and the bulb turnedout white, i mean the filament should be visible rite? but in my case the bulb shell itself became white, cant see through anything
 
Joined
Aug 24, 2009
Messages
1,055
Likes
15
Location
Bangalore
@ blackbeauty , as far as I understand, left and right inductors have 2 separate fuses.

@ napster, with out any doubt either your fuse / resistance for right indicator is gone or your fused bulb is causing the trouble. Try replacing the bulb first [:)]
 

napster

Suspended
Joined
Aug 23, 2009
Messages
545
Likes
8
Location
AP-09
@ napster, with out any doubt either your fuse / resistance for right indicator is gone or your fused bulb is causing the trouble. Try replacing the bulb first [:)]
i removed the bulb and tested it, the same problem existed, im going to my service centre tomo, hope it gets fixed wihtout any replacement of expensive parts
 
Thread Starter #11
Joined
Sep 21, 2009
Messages
24
Likes
0
Location
Trichy
They said it was some loose connection. The mechanic checked something under the steering & bonnet and said "the problem is rectified". Then i took the car back to home and within few kilometers the problem started again. So, i just complained in maruti's customer care about these things and they assured me that they will take necessary action.
 
Joined
Sep 23, 2009
Messages
30
Likes
2
Location
Solapur, Maharashtra
If I am Correct, there are four Indicator Bulbs for each side.
1. At the Front End - near or inside Headlight Assembly.
2. On the Instrument Cluster - Inside the car.
3. On the Front Fenders.
4. At the Rear End - near or Inside Taillight Assembly.

Either of these blows, then the remaining ones keep glowing continuously instead of blinking. So check all the four Bulbs on the Right Side.
 
Joined
Aug 24, 2009
Messages
1,055
Likes
15
Location
Bangalore
If I am Correct, there are four Indicator Bulbs for each side.
1. At the Front End - near or inside Headlight Assembly.
2. On the Instrument Cluster - Inside the car.
3. On the Front Fenders.
4. At the Rear End - near or Inside Taillight Assembly.

Either of these blows, then the remaining ones keep glowing continuously instead of blinking. So check all the four Bulbs on the Right Side.

You are correct [thumbswink]
 
Thread Starter #14
Joined
Sep 21, 2009
Messages
24
Likes
0
Location
Trichy
But All the bulbs are working good.

Today i opened the fuse box under the steering wheel and checked whether all the fuses are good. When i pressed a fuse little bit hard (3rd fuse i think so) the indicator started working good. And if i take the hand or shake it lightly the indicator stops blinking and glows continuously.
 
Top Bottom