The Pony Car - Ford Fiesta 1.6 SXi 2009 (Pre-Tamed Beast)


Joined
Dec 20, 2014
Messages
52
Likes
28
Location
KA04 / KA15
2.65 for a 10 year old looks bit a pricey one.

I have 2008 1.6 SXI Duratec(petrol) with 55K on Odo which was quoted max of 2.1. Of course all the tyres are new and it is in prestine condition.
 
Thread Starter #93
Joined
Sep 11, 2009
Messages
2,184
Likes
1,703
Location
Trivandrum
Yeah. Very pricey and pretty high odo. Even what we paid for our's is considered very high by everyone in the extended family and every mechanic we met.
 
Thread Starter #94
Joined
Sep 11, 2009
Messages
2,184
Likes
1,703
Location
Trivandrum
September 2019 - Continues:

Renewed insurance. New India. Premium ₹ 12,643.00. IDV ₹ 2,20,000.00.
Glad that they still offer full cover for a 10-year-old car.

Rain continues. Offroader. Mud racer.

2019-09-01 12-37-57_3.jpg
2019-09-01 14-00-56.jpg


Washing in rain.

2019-09-02 18-09-25.jpg


Hard to make the tyres black again. Got some kind of brush from a nearby grocery shop that came very handy. Mom's Vim liquid did the trick.

2019-09-02 18-27-24.jpg
2019-09-02 18-27-47.jpg


Ready to park.

2019-09-02 18-55-36.jpg


Again with the visitor. @vishnu vichu's S.

2019-09-01 21-23-29.jpg
 
Thread Starter #97
Joined
Sep 11, 2009
Messages
2,184
Likes
1,703
Location
Trivandrum
October 2019:

Just past the second year, the second one of the expensive Phillips low beam bulb konked off. Decided to go with stock bulb, but again the annoying high beams of P220 came into mind, they were H7 as well. Checked 99rpm.com to cross-check and was cheaper than Ford OEM by 25%. Just checked with a small Bajaj dealer on the way to the office and got'em.
Bajaj - DK201043 - ₹ 294.00/each.

2019-10-02 19-42-07.jpg


Glass is blue, but not evident in photo.

2019-10-02 19-43-06.jpg


Expected Halonix, but turned out to be some Pheonix brand.

2019-10-02 19-43-30.jpg
2019-10-02 19-43-46.jpg


Comparing with the Phillips X-treme Vision H7.

2019-10-02 19-56-05.jpg
2019-10-02 19-56-22.jpg


Whitishness.

2019-10-02 20-01-29.jpg


Low vs high color temperature difference.

2019-10-02 21-57-28.jpg
2019-10-02 21-58-17.jpg


The output is also similar to X-treme Vision. Gotta find an ernative for high beam as well, in case.
 
Thread Starter #98
Joined
Sep 11, 2009
Messages
2,184
Likes
1,703
Location
Trivandrum
October 2019: Never ending rain.

2019-10-07 13-24-39.jpg
2019-10-07 13-36-38.jpg


Power sharing. Polo battery dead. Replaced with new one. No cable, so swapped battery and started and put it back.

2019-10-21 10-58-39.jpg


December 2019: Mischievous pussy attack [sad]

2019-12-08 09-57-48.jpg
 
Thread Starter #99
Joined
Sep 11, 2009
Messages
2,184
Likes
1,703
Location
Trivandrum
January 2020: Gets Bluetooth'd

Had the Tantra Fluke Pro Bluetooth Receiver bought for Polo >> Polo Gets Tantra Fluke Pro Bluetooth Receiver
Since Polo was sold and EcoSport had Bluetooth connectivity, Fluke was lying around unused. So, lifted it for Pony [evil]

Got a Tantra Fluke Pro Bluetooth Receiver from Amazon. ₹ 1,800.00. Sound quality was excellent, both for music playback and phone calls. Connects in less than 2 seconds every time. No lag with changing tracks. Connects to HU's aux port and can be powered with HU USB. Extra long cable to mount anywhere in the dash.
Threw away the el-cheapo Bluetooth/USB module.

2020-01-01 11-32-36.jpg


Perfect spot for the mount. Double-sided tape and it goes there.

2020-01-01 11-35-21.jpg


Sits perfectly on the magnetic mount.

2020-01-01 11-39-56.JPG


Power and aux close by, so no dangling wires.

2020-01-01 11-40-27.JPG


Red when not connected.

2020-01-01 11-40-52.JPG


Blue when connected.

2020-01-01 11-41-49.JPG


Now no reason to change the otherwise superb sounding HU. Maybe USB is missing, but that is slowly becoming obsolete.
 
Thread Starter #100
Joined
Sep 11, 2009
Messages
2,184
Likes
1,703
Location
Trivandrum
February/March 2020: Throttle issues.

One fine night while driving, the car started acting weird, no throttle response, but was idling properly. Managed to reach home in idle rpm. It didn't stall in higher gears as well or at the inclines. Drove some 2-3 km. Checked loose contacts. Called up @vishnu vichu, who said throttle body would be blocked. Decided to give to Ford the next week since didn't want to mess up with the not so friendly Fords.

2020-02-27 21-05-13.jpg


Plugged OBD and scan gave this result.

Screenshot_2020-03-09-17-29-09-031_org.prowl.torque.jpg


Some Google-ing and grabbed tools and went DIY.

Popped hood.

2020-03-09 17-12-15.jpg


Pulled out the hose.

2020-03-09 17-57-52.jpg


Weirdly positioned, but easily accessible throttle body.

2020-03-09 17-57-37.jpg


Muck and stuck. Started the car and it wasn't budging a bit, once pushed with hand it started working, but sticking and no linear movement.

2020-03-09 17-57-39.jpg


Just a push got finger this dirty.

2020-03-09 17-57-09.jpeg


In the crucial time, there was no throttle body cleaner in my stock and the Threebond Parts cleaner also ran out. So managed with the Wurth Rust Off. Ordered a TB Cleaner right away.

2019-11-07 19-42-17.jpg


Sprayed a bit and it started coming off. Two-three rounds and it completely cleared off. Anyway will redo once TB cleaner is procured.

2020-03-09 17-59-36.jpg
2020-03-09 18-00-55.jpeg


The weirdo Ford clip. Hard to fasten in that tight gap. Managed to fit back after almost half an hour of fight.

2020-03-09 17-57-56.jpg


All set and done. Reset battery. Took it for spin. Throttle was working absolutely normal.

2020-03-09 18-32-40.jpg


Further scan showed no error.

Screenshot_2020-03-09-20-34-52-842_com.ovz.carscanner.jpg


Happy ending.
 
Thread Starter #102
Joined
Sep 11, 2009
Messages
2,184
Likes
1,703
Location
Trivandrum
Its a slight risk that you took spraying anti rust instead of Throttle body cleaner , aren't the compositions different ?
Just for cleaning purpose anything will do, just make sure not to spray rich. A little bit to soak the dirt and wipe it off. Leaving residue will attract more dirt. This was just a stop-gap cleaning. Bought TB cleaner already. BTB most mechanics use rust off and petrol only for cleaning purposes [lol]
 
Thread Starter #104
Joined
Sep 11, 2009
Messages
2,184
Likes
1,703
Location
Trivandrum
March 2020: In search of the cause.

Faulty air filter should be 90% the cause of a dirty throttle body. 10% can be leak in box or plumbing.

The thing every Fiesta owner/mechanic hate, unscrewing the air filter bolts. Removing the box is another headache.

2020-03-27 13-01-01.jpg


Tadaa [evil] Removed all of them in a minute (or maybe 2 [lol])

2020-03-27 13-00-42.jpg

2020-03-27 13-00-53.jpg


The cause, wrong filter [frustration] I expected rat attack.

2020-03-27 13-02-22.jpg


There was gap in both sides of the filter.

2020-03-27 13-02-26.jpg


The filter was pretty clean for 10k km of use, meaning air flow was minimal through the filter.

2020-03-27 13-02-39.jpg


If belongs to Opel Corsa and costed more than twice the Ford OEM filter. Done by Travancore Motors. See the folds in the filter as well. It didn't fit inside the box, they squeezed it in.

2020-03-27 13-02-46.jpg
2020-03-27 13-03-33.jpg


Next was overtightening the bolts, causing them to sink too much.

2020-03-27 13-18-39.JPG


and puncturing through the cover.

2020-03-27 13-18-23.JPG


Added washers to prevent further damage.

2020-03-27 13-18-48.JPG


All cleaned and installed back. Managed to install the filter without any gap, but still risky. Would get stock filter as soon as the Ford service center are up.

2020-03-27 13-22-47.JPG
 
Top Bottom