Tata Tiago: Technical Issues & Solutions


Joined
Aug 15, 2013
Messages
773
Likes
716
Location
Bangalore
Its enough for a petrol engine to idle for 15 seconds.


Still will report this thing at the first service.
Yes the idle time is too much in Tiago. I think 25secs should be enough. When my car was new I used to feel that cold start jerk many times but after driving around 1400 kms its much better now and I dont feel cold start jerks. I never idle since whenever I have to take car in the morning I am in hurry. I have another issue if I don't idle. The car feels overpowered when I first time use second gear without idling. I have to brake hard as it feels like taming a bull. After that it gets normal. Not a big issue for me but new drivers need to be careful.

One issue I have is the parking sensor plays too safe sidewise and when parking in tight spots it gives false warnings as there would be sufficient space not to hit sideways. Wish they reduce sideways sensitivy. Has anyone else faced this?
 
Thread Starter #32
Joined
Apr 25, 2016
Messages
1,267
Likes
2,082
Location
Coimbatore
The car feels overpowered when I first time use second gear without idling. I have to brake hard as it feels like taming a bull. After that it gets normal.
This is because of raised RPM levels until warm up. As you said, we owners will get used to it over time. First timers will not like this for sure.

One issue I have is the parking sensor plays too safe sidewise and when parking in tight spots it gives false warnings as there would be sufficient space not to hit sideways. Wish they reduce sideways sensitivy. Has anyone else faced this?
I have noticed this too. Corner sensors are over sensitive and often ends up with false alarms.
 
Joined
Oct 25, 2015
Messages
925
Likes
1,153
Location
Mumbai
One issue I have is the parking sensor plays too safe sidewise and when parking in tight spots it gives false warnings as there would be sufficient space not to hit sideways. Wish they reduce sideways sensitivy. Has anyone else faced this?
I too feel its over-sensitive, so I check orvm and tend to over-rule it. The rear seasors (middle two) too feels sensitive to me.
If it shows 'STOP' on ICE there is still 12" back.
 
Joined
Jun 30, 2015
Messages
27
Likes
33
Location
Raipur-Chhattisgarh
I have TATA ZEST XT RT and GEX NANO XT MT. By habit of start Zest, I follow settling idle my NANO for approx 20-25 sec then move further. We should follow this for all brands for smooth ride and engine performance.
 
Joined
Oct 25, 2015
Messages
925
Likes
1,153
Location
Mumbai
Joined
Oct 25, 2015
Messages
925
Likes
1,153
Location
Mumbai
Diesel Tiago owner here,

1. Engine Mounts :-
Fed-up of A engine mounts breaking after every 2,000 km.

Though​ it will be replaced under warranty, FOC but still why can't TATA overcome this issue?

2. ECU update :-
Mine is August 2016 manufactured, got ECU update.
Diesel clatter is non-existent and vibrations have reduced, pickup have increased. Feels so silent. Have to check whether it has taken impact on FE or not.

3. Suspensions :-
They are really delicate, and tends to loose up when going over pothole.
Got car back from second service on Friday, today hit a pothole at around 40 kmph, and can hear suspensions loosing up.
 
Joined
Apr 16, 2017
Messages
2
Likes
0
Location
Shillong
Hi, been driving Tata tiago for almost 10 months and was pretty happy with the car, but yesterday the Harman infotainment system is not turning on. Can you assist or suggest me some solutions. I don't know how much help will I get from the local tata dealer here. Thanks
 
Last edited by a moderator:
Joined
Oct 25, 2015
Messages
925
Likes
1,153
Location
Mumbai
Hi, been driving Tata tiago for almost 10 months and was pretty happy with the car, but yesterday the Harman infotainment system is not turning on.... Can u assist or suggest me some solutions... I don't know how much help will I get from the local tata dealer here... Thanks
Fuse must have blown (most common issue) or HU issue.
 
Thread Starter #43
Joined
Apr 25, 2016
Messages
1,267
Likes
2,082
Location
Coimbatore
As Gautam suggested please check the fuse below steering wheel. You will have to open the plastic trim to access fuse box.
 
Joined
Apr 25, 2017
Messages
1
Likes
0
Location
Noida
Hi everyone,

I have faced a problem
Outside temprature : 44 C
Driving speed: 110 KMPH
AC: On,
Load: 3 people
I was driving on 23 April 12 AM noon. I have almost completed 250 KM from Lucknow TAJ expressway. Suddenly my car started slowing down 100,80,70... untill it stopped. I restarted after 5 minutes but again after 2 Km same problem occured.

I waited for 30 minutes. After that I started and completed the rest 270 KM without any problem.

My question is
1. Is it a heating problem?
2. Is it happened to anyone else.
 
Thread Starter #45
Joined
Apr 25, 2016
Messages
1,267
Likes
2,082
Location
Coimbatore
Hi Vinay,
That is a very scary scenario. Did you take your car to service center and have them check for error codes in ECU? Please also answer below questions for our forum members to be able to pour in their troubleshooting:
1. Petrol or Diesel?
2. What was your temperature gauge reading? If it is a overheating problem, you would see it more than 3 bars.
3. Any warnings/lights lit up in instrument cluster?
 
Top Bottom