Tata Nexon Ownership Review: Living The Nexon Life


Thread Starter #827
Joined
May 16, 2014
Messages
1,406
Likes
2,536
Location
kanpur
Changing Nexon's coolant at home as a DIY.
It has been 3 years already with the Nexon ,and I was noticing deposits in the coolant degassing bottle. I wanted to do it myself at home,so I purchased 4 litres of coolant and went about changing it with the help of my son.



Disconnected the battery first
IMG-20201024-WA0015.jpg







4 litres of Tata motors Original coolant
IMG-20201024-WA0038.jpg
IMG-20201024-WA0032.jpg








Coolant draining from below
IMG-20201024-WA0018.jpg






I collected all the coolant in a container to measure how much came out
IMG-20201024-WA0020.jpg












Debris in the old coolant
IMG-20201024-WA0001.jpg
IMG-20201024-WA0009.jpg








Despite collecting it some of it spilled on the ground
IMG-20201024-WA0011.jpg










Collected all of it in a container to dispose off in an environment friendly nature
IMG-20201024-WA0039.jpg









Tools used
IMG-20201024-WA0034.jpg
IMG-20201024-WA0035.jpg









After changing cool blue colour
IMG-20201024-WA0036.jpg
IMG-20201024-WA0037.jpg
IMG-20201024-WA0025.jpg








Old coolant was dirty, dark and debris filled
IMG-20201024-WA0027.jpg
IMG-20201024-WA0028.jpg
IMG-20201024-WA0029.jpg






Tool box
IMG-20201024-WA0030.jpg
IMG-20201024-WA0031.jpg
IMG-20201024-WA0016.jpg
IMG-20201024-WA0017.jpg
IMG-20201024-WA0018.jpg
IMG-20201024-WA0019.jpg
IMG-20201024-WA0020.jpg











Coolant bleeding on the ground: Blue Blood!!
IMG-20201024-WA0021.jpg
IMG-20201024-WA0022.jpg
IMG-20201024-WA0023.jpg
IMG-20201024-WA0024.jpg
IMG-20201024-WA0008.jpg
IMG-20201024-WA0009.jpg








Tools used in the red toolbox
IMG-20201024-WA0033.jpg
IMG-20201024-WA0014.jpg
IMG-20201024-WA0013.jpg






This funnel came in very handy
IMG-20201024-WA0003.jpg



I idled the car for 15 minutes.Coolant level went down.I filled up again.I repeated the procedure 4 times. I opened the AC vents to full heat during all this.
Hope it helps other Nexon owners!
I enjoyed the DIY very much. Thanks for watching and reading!!
 
Last edited:
Joined
Jul 23, 2020
Messages
145
Likes
221
Location
Coimbatore
Hello Doc, did you not flush the radiator? It is always advised to flush the coolant when you find some debris. You can use Distilled water and vinegar to flush the coolant. I think if you fill directly in the radiator, you wouldn't have had to fill the reservoir 4 times(Correct me if I am wrong).
 
Joined
Sep 11, 2009
Messages
2,318
Likes
1,894
Location
Trivandrum
Hello Doc, did you not flush the radiator? It is always advised to flush the coolant when you find some debris. You can use Distilled water and vinegar to flush the coolant. I think if you fill directly in the radiator, you wouldn't have had to fill the reservoir 4 times(Correct me if I am wrong).
Most of the cars don't have direct access to radiator nowadays and no radiator caps. I think that's the case with Nexon also.
 
Thread Starter #830
Joined
May 16, 2014
Messages
1,406
Likes
2,536
Location
kanpur
Hello Doc, did you not flush the radiator? It is always advised to flush the coolant when you find some debris. You can use Distilled water and vinegar to flush the coolant. I think if you fill directly in the radiator, you wouldn't have had to fill the reservoir 4 times(Correct me if I am wrong).
No I didn't flush the radiator. I removed the exit valve and radiator was drained through that only. Car is not old and coolant was not that dirty so I didn't flush it. I repeated the procedure 4 times to get rid of the air trapped. Bubbles keep coming out and to fill back completely press the hoses of radiator repeatedly after its becoming hot,to remove the trapped air. It takes quite long to remove the trapped air fully.



Most of the cars don't have direct access to radiator nowadays and no radiator caps. I think that's the case with Nexon also.
Correct. I will have to put water in the plastic bottle to do the flush and it will never come out fully. It will mix with the coolant.
 
Last edited:
Joined
Jul 23, 2020
Messages
145
Likes
221
Location
Coimbatore
Most of the cars don't have direct access to radiator nowadays and no radiator caps. I think that's the case with Nexon also.
Oh ok. I too haven't seen radiator cap in my Tiago. Thought I should I should remove somethings to get access and didn't bother to look at it.

No I didn't flush the radiator. I removed the exit valve and radiator was drained through that only. Car is not old and coolant was not that dirty so I didn't flush it. I repeated the procedure 4 times to get rid of the air trapped. Bubbles keep coming out and to fill back completely press the hoses of radiator repeatedly after its becoming hot,to remove the trapped air. It takes quite long to remove the trapped air fully.
I know this method and tried in my duke 390. Coolant didn't drain completely. Had to open the radiator cap. I thought cars also have same procedure and didn't know that cars don't have access to radiator now a days. Thanks for clarifying.
 
Thread Starter #832
Joined
May 16, 2014
Messages
1,406
Likes
2,536
Location
kanpur
Oh ok. I too haven't seen radiator cap in my Tiago. Thought I should I should remove somethings to get access and didn't bother to look at it.


I know this method and tried in my duke 390. Coolant didn't drain completely. Had to open the radiator cap. I thought cars also have same procedure and didn't know that cars don't have access to radiator now a days. Thanks for clarifying.
Cars do have the same procedure,but it's nowhere written in my manual about flushing coolant.It's only changing. Flushing can be done,but it's a tricky and lengthy procedure.
Moreover it was not required. My erstwhile Swift vxi and Ritz vxi had a separate radiator caps,and there flushing was easy.
 
Last edited:
Joined
Oct 22, 2018
Messages
16
Likes
9
Location
Ranchi
Hello Sir @mayankdixit
Facing a strange problem. Front and rear side parking light automatically shut off after some time. But again it works fine after switching on off. Kindly tell me how can I fix it. One more thing, kindly share a closer shot of drainage point, from where u have drained out the old coolant.
Regards
 
Thread Starter #834
Joined
May 16, 2014
Messages
1,406
Likes
2,536
Location
kanpur
Hello Sir @mayankdixit
Facing a strange problem.
1) Front and rear side parking light automatically shut off after some time. But again it works fine after switching on off. Kindly tell me how can I fix it.
2) One more thing, kindly share a closer shot of drainage point, from where u have drained out the old coolant.
Regards
I have put no.to your queries for better answer:
1) Your BCM is acting up.You may have to visit TASS for it.They will reflash it/maybe update it,if it's an older version.
2) Old coolant drainage is near the lower left side of radiator.I will try to take a picture if possible.Its visible by a small black pipe coming out of radiator bottom.
 
Last edited:
Joined
Oct 22, 2018
Messages
16
Likes
9
Location
Ranchi
I have put no.to your queries for better answer:
1) Your BCM is acting up.You may have to visit TASS for it.They will reflash it/maybe update it,if it's an older version.
2) Old coolant drainage is near the lower left side of radiator.I will try to take a picture if possible.Its visible by a small black pipe coming out of radiator bottom.
@mayankdixit
Thanks a lot sir.I will visit TASS as soon as possible and update BCM. I will also try to change the coolant under your guidance. Mine is 2.5 years old.
 

Akash1886

Honoured Member
Joined
Sep 7, 2014
Messages
11,464
Likes
14,042
Location
Delhi-NCR/ Mumbai
@mayankdixit @RKKOLLIPARA @gearhead2 @J.Ravi @Nanofreak

Brothers & Seniors[:)]

Wanted to inform about 2 false alarms on the speedo console of my Nexon.

1) The "Fuel Reserve Light" switched on at 169 Kms for about a few hours and then went off on it's own.

2) Check Engine Light started to blink along with another indication when I cranked the engine while car was parked at a parking lot. Until I reached home, the same check engine light kept blinking and once when I opened the bonnet and looked inside there wasn't any issue of any sort. Restarted the car, all was back to NORMAL

Now, what to do and what could be possible cause of the issue?

Regards
Akash
 
Joined
Oct 15, 2011
Messages
5,117
Likes
4,478
Location
Some Village
There can be 2 directions here,
1 Rat bites.
2 Bad grounds. Bad grounds are a problem with Safari, not sure about its younger brother Nexon. But could be hereditary. Issues are common in winters are moisture/Dew gets on Ground points between chassis and Grounding nut. Bad ground causes ghost issues.
3. Also check ECU connector (big one) for moisture. A preventive spray of WD40 on connectors, fuses, relays does helps.
 
Joined
Aug 18, 2015
Messages
1,090
Likes
695
Location
Bangalore
@mayankdixit @RKKOLLIPARA @gearhead2 @J.Ravi @Nanofreak

Brothers & Seniors[:)]

Wanted to inform about 2 false alarms on the speedo console of my Nexon.

1) The "Fuel Reserve Light" switched on at 169 Kms for about a few hours and then went off on it's own.

2) Check Engine Light started to blink along with another indication when I cranked the engine while car was parked at a parking lot. Until I reached home, the same check engine light kept blinking and once when I opened the bonnet and looked inside there wasn't any issue of any sort. Restarted the car, all was back to NORMAL

Now, what to do and what could be possible cause of the issue?

Regards
Akash
Observe few more days if Check engine light comes again do OBD scanning.
 
Thread Starter #839
Joined
May 16, 2014
Messages
1,406
Likes
2,536
Location
kanpur
@mayankdixit @RKKOLLIPARA @gearhead2 @J.Ravi @Nanofreak
1) The "Fuel Reserve Light" switched on at 169 Kms for about a few hours and then went off on it's own.
2) Check Engine Light started to blink along with another indication when I cranked the engine while car was parked at a parking lot. Until I reached home, the same check engine light kept blinking and once when I opened the bonnet and looked inside there wasn't any issue of any sort. Restarted the car, all was back to NORMAL
Now, what to do and what could be possible cause of the issue?
You could have avoided driving the car till your home when CEL came on as soon as you cranked ! You could have tried "switch on-wait-off -wait for 10 min-on again" there in the parking only.
I agree with @bhvm and @Suryaputhra .It might be a rat bite. Please observe more for 1-2 days and see. Also have a look at these queries too.
Was the rpm erratic when you switched on the car?
Was the car serviced recently?
Was the engine bay cleaned/pressure washed recently?
 
Last edited:

Akash1886

Honoured Member
Joined
Sep 7, 2014
Messages
11,464
Likes
14,042
Location
Delhi-NCR/ Mumbai
You could have avoided driving the car till your home when CEL came on as soon as you cranked ! You could have tried "switch on-wait-off -wait for 10 min-on again" there in the parking only.
Bhai I too didn't want to but Papa thay sath mein. So, he was getting tensed and told me to drive it back home and then see what can be done. I drove back home at speed of 30-40 km/h with flasher on.

I agree with @bhvm and @Suryaputhra .It might be a rat bite.
Actually rat bites aren't possible since no wires etc looked damaged to me but yes I too agree with @bhvm babu on the ghost issues and bad grounds.

@Suryaputhra, bro since the incident, it has been a week+ and nothing happened again. It seems a false alarm by the car.

Please observe more for 1-2 days and see. Also have a look at these queries too.
Was the rpm erratic when you switched on the car?
Though the CEL hasn't come back again since a week+ but yes on the day of incident, for a good 3-4 minutes, the car was shaking, engine sound wasn't the same as the diesel engine sound and the RPM which remains around 800-900 was about 1300-1400 for the duration of 3-4 minutes.

Was the car serviced recently?
Was the engine bay cleaned/pressure washed recently?
No

To you all, @bhvm @mayankdixit @Suryaputhra

As it's very cold in our side of the state, tell me something, how much time normally does the 'GLOW PLUG' sign takes to go off post first crank of morning?
Secondly, Mayank and BHVM, how long do the bulbs used by TML last? MY car's tail light bulb (brake wala) has fused again about a month ago. Last year that same bulb was changed after it fused. My earlier cars never had such small but pinching issues.

Though I'll also be posting pics later in the day, Please tell me, my car is nearing 22K and the Good Year Tires aren't holding up, from the present condition, my car may need a new set around 30-33K mark. Is it normal? I don't drive rash and neither any long drives or on hilly terrains and as much as possible, I try to avoid bad roads too.

Regards
Akash
 

Top Bottom