My Own Tata Nano LXi Thread :)


Varun560061

Honoured Member
Joined
May 1, 2011
Messages
3,593
Likes
752
Location
Bangalore
Is it the fresh intake valve where the hot air is coming in ?

Also check for missing rubber boots on the firewall(behind the dash).
This too causes the hot air to pass into the cabin.
 
Joined
Jul 9, 2011
Messages
420
Likes
120
Location
Indore
I am getting only 14-15 kmpl in city, any guess what might be the problem, also the car takes hicc-ups some times like if there is no fuel.
 
Thread Starter #48
Joined
Aug 26, 2012
Messages
42
Likes
3
Location
Mumbai
I am getting only 14-15 kmpl in city, any guess what might be the problem, also the car takes hicc-ups some times like if there is no fuel.
In extreme city conditions, the average you're getting may not be surprising. Some people here have had problems with premium fuel, so hope you're not using that.

About car taking jerks, that's certainly not normal. Have the vehicle checked.
 
Thread Starter #49
Joined
Aug 26, 2012
Messages
42
Likes
3
Location
Mumbai
I did Mumbai - Delhi and back a few days ago. Car returned FE of 20.5 kmpl with blower on all the time and the AC/heater on half the time. Car is capable of cruising at its top speed over extended periods. I did not have any problems with the car. Total distance travelled was about 3300 kms.
 
Joined
Apr 11, 2012
Messages
150
Likes
90
Location
Thane
I did Mumbai - Delhi and back a few days ago. Car returned FE of 20.5 kmpl with blower on all the time and the AC/heater on half the time. Car is capable of cruising at its top speed over extended periods. I did not have any problems with the car. Total distance travelled was about 3300 kms.
Can you please post your travelogue experience (with pics) of this trip?
If you already have, may I please get the link to your travelogue?
 
Thread Starter #51
Joined
Aug 26, 2012
Messages
42
Likes
3
Location
Mumbai
Can you please post your travelogue experience (with pics) of this trip?
If you already have, may I please get the link to your travelogue?
Hi. Unfortunately, I didn't take any pics along the way. I have fuelling logs but nothing else :-(
 

Top Bottom