My Maruti Suzuki Alto LXi


Thread Starter #16
Joined
Dec 30, 2011
Messages
674
Likes
293
Location
Kollam
Good mileage, not bad for a learner [thumbsup], keep trying i bet you will get 17kmpl in city[:)]
Thanks bro.:)

@ All

My HU(Mitsun MIT222) was not working,Removed it and opened it and found that the USB port is broken,searching for USB port matching it.:)

Some Clicks.:)

Photo0166.jpg

Wiring:
Photo0169.jpg

What is that black thing?

Photo0168.jpg
 
Last edited:

lxi.

Suspended
Joined
Jan 6, 2012
Messages
916
Likes
13
Location
New Delhi
Congrats on your Alto!
Its a very good, indeed best, car for new drivers.
Actually your speakers are mounted the right way (IMO), because in my Suzuki, they are on the parcel tray, so have to compromise on the boot space. Dont waste your precious money on the Wheel covers, get some nice 12" alloys and your car is a stunner. I have already wasted 600Rs. and two of them broke off while the tyre changing after puncture and the colour got yellowish. So removed them and got hubcaps (small ones on the centre with Suzuki mark) no breaking, easy to remove and install for 200Rs.

Actually i feel the mods i am listing below are adequate for an alto -

1. Tints (not done on mine)
2. B pillar blakc tape (not done)
3. 5 Spoke 12" Alloys (planning the coming month)
4. Nice HU with nice speakers (Sony HU with pioneer A series speakers)
5. 1100w Sub with 2 channel Amp (planning to do)
6. 155/75 R12 Tyres (mine are stock JKs and are in nice condition)
7. Fog lamps (aftermarket ones, planning this sunday)
8. clam shell (k10) type ORVMs (getting this weekend)

Hope this helps you!
It will cost aproxx. Rs.50000 (less than this i think)

Cheers!
 
Thread Starter #18
Joined
Dec 30, 2011
Messages
674
Likes
293
Location
Kollam
Congrats on your Alto!
Its a very good, indeed best, car for new drivers.
Actually your speakers are mounted the right way (IMO)
One of my friend said that fitting speakers on the rear door will damage the hydraulic thing which holds the door.Is it true?[confused]

Dont waste your precious money on the Wheel covers, get some nice 12" alloys and your car is a stunner. I have already wasted 600Rs. and two of them broke off while the tyre changing after puncture and the colour got yellowish. So removed them and got hubcaps (small ones on the centre with Suzuki mark) no breaking, easy to remove and install for 200Rs.
Was planning to get alloys,but now my budget wont allow that.[cry]


4. Nice HU with nice speakers (Sony HU with pioneer A series speakers)
Stay away from Sony and JBL HU,Get pioneer,kenwood,etc)

6. 155/75 R12 Tyres (mine are stock JKs and are in nice condition)
It makes the speedometer reading weird.
 
Thread Starter #19
Joined
Dec 30, 2011
Messages
674
Likes
293
Location
Kollam
Changed oil & More

Changed oil today,Have a look at the pics:

When drained the old oil.[frustration]

I have to pour in full 3L of oil.(I mean i poured in full bottle of oil i bought,it was 3L bottle) still its a bit less than the max level in the gauge.Is it OK?
Manual says it needs about 2.7ltrs only,but i have to pour in full.[confused]

Fixed new OilFilter,I removed old one and fixed new one with hand and made sure that there is no oil leaks.Where can i buy the oilfilter removing tool?

Poured in new oil. MG Oil 20W40
Also check that bush of arm,Is that bush OK?
Pic of old filter attached.

Found Pioneer TS-S250,In new condition(NOT WORKING :D )

HU not working,modded the USB port,but still its dead!!![frustration]
 

Attachments

Last edited:
Joined
Sep 4, 2011
Messages
3,647
Likes
282
Location
Mumbai MH01/MH46
im not sure about capacities in the alto but is it written 2.7l with filter or without it? if its below max level top it up just ensure its not less then then between max and minimum.
and boy the old oil was dirty how long has it been in there?
i did an oil change of my car today. way earlier then the prescribed interval and it was as black as your oil even though the oil has been filled at factory.
cheers i see an alto in pretty good and caring hands
 
Thread Starter #23
Joined
Dec 30, 2011
Messages
674
Likes
293
Location
Kollam
im not sure about capacities in the alto but is it written 2.7l with filter or without it?
I guess its without Filter.

if its below max level top it up just ensure its not less then then between max and minimum.
Its one or 2 cm below the max mark.Seems like its OK.

and boy the old oil was dirty how long has it been in there?
Dont Know,I think its older than 10000kms.[frustration]

i did an oil change of my car today. way earlier then the prescribed interval and it was as black as your oil even though the oil has been filled at factory.
I am planning to replace every 5000kms.Now its 45903kms,will do next oil change at 50000kms.[:)]

cheers i see an alto in pretty good and caring hands
I love DIY & Special thanks to people like you, for sharing knowledge with people like me.[cheers]

Any idea about the Oil Filter removal tool and coolant fill?
 
Joined
Sep 4, 2011
Messages
3,647
Likes
282
Location
Mumbai MH01/MH46
for the oil filter you could use any one of these two.
http://www.ntxtools.com/Merchant/graphics/00000001/otc-6905.gif which i will eventually use for my car since the position of the filter is vertically fitted near the oil sump.

and
http://www.classic-car-magazine.co.uk/articles/images/oil_change/oil_filter_wrench.jpg this would be helpful otherwise can be used for me also but would take some effort.

regarding the coolant i read somewhere it is 2.5l I'm not sure about the amount of water and coolant but my service guys for my other cars add 50% coolant and 50% water. A good parts shop can help you if its not given in the owners manual and also which type of coolant to use as new cars with aluminum radiators need specific coolant meant for them
 
Thread Starter #25
Joined
Dec 30, 2011
Messages
674
Likes
293
Location
Kollam
for the oil filter you could use any one of these two.
Where can i buy these?

regarding the coolant i read somewhere it is 2.5l I'm not sure about the amount of water and coolant but my service guys for my other cars add 50% coolant and 50% water. A good parts shop can help you if its not given in the owners manual and also which type of coolant to use as new cars with aluminum radiators need specific coolant meant for them
Will get this done from a good mechanic and will let you know guys.
 
Thread Starter #26
Joined
Dec 30, 2011
Messages
674
Likes
293
Location
Kollam
Guys my reverse light is not working,I removed both the tail lights and checked for any problems and found that the reverse buzzer is damaged with water,so i removed it and still its not working,What is the problem and how can i rectify it?[confused]

A Pic of my car's Engine Bay! [:)]
 

Attachments

Last edited:
Joined
Dec 15, 2011
Messages
2,536
Likes
1,305
Location
M.P.
Always good to see a clean engine bay. For non-functional reverse light, first check the bulb. If that's alright, check connectors next. If the connectors too are lose, there could be a short somewhere or the actuator (the spring loaded part that activates the reverse light when the reverse gear is engaged) might not be functioning properly.
 
Thread Starter #28
Joined
Dec 30, 2011
Messages
674
Likes
293
Location
Kollam
Always good to see a clean engine bay. For non-functional reverse light, first check the bulb.
Yes,the bulb's filament is there.Guess its not a blown.

If that's alright, check connectors next. If the connectors too are lose, there could be a short somewhere or the actuator (the spring loaded part that activates the reverse light when the reverse gear is engaged) might not be functioning properly.
Where is this connector situated? Any pics or Parts catalogue?[confused]
 

Vishwas

Moderator
Joined
May 11, 2011
Messages
4,090
Likes
948
Location
Bangalore
Guys my reverse light is not working,I removed both the tail lights and checked for any problems and found that the reverse buzzer is damaged with water,so i removed it and still its not working,What is the problem and how can i rectify it?[confused]
Check the wiring or the lining it maybe chewed by rats which is a friend of Alto!

A Pic of my car's Engine Bay! [:)]
That's a nice picture, i used to see this type of condition in my alto for a week after it was delivered :stupid:
 

Top Bottom