Maruti Wagon-R Suddenly Halts on Road - Please Advice


Thread Starter #1
Joined
Jul 4, 2011
Messages
9
Likes
0
Location
Delhi
Hi friends, I purchased a used wagon R lxi 2007 model through my friend who is into car sale and purchase business and also took a friend who has good knowledge of cars,after purchasing ,I installed CNG in it, the car game me numerous problems like the house pipe got burst, it was heating up,ac not working,the head issue, my friend got it done,now the issue is whenever the car runs few kms and stops,it would not start,my friend also got the self cleaned,head repaired but the problem persists, I showed it to a local mechanic who told that there is a battery problem, i replaced the battery and the car ran fine for 2-3 days however the same problem arised again,i had to either get the car pushed or wait for half an hour or more for it go get cool and start again , it has become a nightmare to me as I have spent a huge amount on this and cant afford anymore but the problem still remains, after the purchse i also realised that the engine of the car was overhauled ,the mechanic who had adviced me of changing battery says engine is fine and has no issues,he also told me to check the oil level as it can be head issue too, kindly advice what could be the root cause of the problem,i ll be grateful,also i realise that the milegae in petrol and CNG it is giving is not good enough
 
Joined
Jun 20, 2011
Messages
267
Likes
34
Location
chennai
It looks familiar to me. AC not working and stops after few kms.

Please check whether the condenser fan runs properly when the AC is turned on. And it should also turn on if engine heat is getting high. Mostly this should be the problem. If its not working properly , AC wont work, and due to over heating, the car will stop after few kms(did u check the temperature gauge in your dash?). And as u said , it wont start as if there is no battery left to start, but the problem is overheating(some mechanism which stops engine from starting when heat is too high).

In my wagonR(i had it last month) , the problem was the condenser fan fuse. So please check and report.

Hope it helps

Jeno[cheers]
 
Thread Starter #3
Joined
Jul 4, 2011
Messages
9
Likes
0
Location
Delhi
thanks a ton for your kind advice, actually i m not car savvy and havve just learnt the basics, there is no AC problem, the ac was serviced and i got the gas filled, AC is pretty effective ,the mail problem is that the car wont start after geting heated till either you get it pushed or wait for 20-30 min,the tempratue gauge is always below 50 all this while

i got the alternator checked which is fine but the previous mech told it seems only the battery problem,after replacing the battery ,the problem did not arise for 2-3 days,could it be something related to battery that after geting heated, it is not passing the current,please advice,thanks in advance
 
Joined
Jun 16, 2011
Messages
37
Likes
0
Location
Pune
Reading your problem i really dont feel anything is wrong with the battery...If the Battery was the problem maker then you would not have been able to start your vehicle.
 
Thread Starter #5
Joined
Jul 4, 2011
Messages
9
Likes
0
Location
Delhi
thats right, the car starts perfectly fine in the morning or after a break,the main issue is while driving few kms,if i stop it, it would not start, there is not enough whrr sound shound when i turn on the keys ,it is really bad and embarassing when it stops in middle of traffic,i stay in delhi and have shown to couple of places who have diagnosed as self/head or battery issue but have not been able to resolve the issue
 
Joined
Jun 20, 2011
Messages
267
Likes
34
Location
chennai
thats right, the car starts perfectly fine in the morning or after a break,the main issue is while driving few kms,if i stop it, it would not start, there is not enough whrr sound shound when i turn on the keys ,it is really bad and embarassing when it stops in middle of traffic,i stay in delhi and have shown to couple of places who have diagnosed as self/head or battery issue but have not been able to resolve the issue
Did the problem occur while driving with AC or without AC, or in both cases? And are u sure that the temperature was controlled??
My guess is, it may be a sensor problem, condenser should switch on, when engine crosses a temperature.

Jeno[cheers]
 

350Z

Core Team
Joined
Aug 10, 2009
Messages
18,428
Likes
6,205
Location
New Delhi
Hi Virr, Welcome to The Automotive India. How many kilometres has your car clocked? I assume this is primarily an overheating issue. There could be certain possibilities. In which part of Delhi you stay? I can recommend Yashwant Place Petrol Pump workshop. There are a couple of Petrol Pumps together. Although the first one is specialized for imported and classic cars but he does the job well on small cars too and sincerely. Second is authorized MSIL Workshop. I got my car’s clutch plate assembly replaced from there. The person is nice. Just in case, you stay that side, consider paying a visit.

Drive Safe,
350Z
 
Thread Starter #8
Joined
Jul 4, 2011
Messages
9
Likes
0
Location
Delhi
thanks all for the concerns,I stay in south delhi near saket, my car has run 55000 kms, regarding the issue, this occurs when AC is on as this being a hot summer, I have been driving on AC all the times for last 3-400 kms,I want to avoid showing it to authorised workshop as for a minor fault they will charge you hefty amount,if there are some main things highlighted, I can show it to a good mech to get that rectified,like you mentioned the sensor problem,thanks
 
Joined
Jul 6, 2011
Messages
191
Likes
3
Location
Rajahmundry
seems the problem is with the starter motor. i had the same problem with my ikon. the car refuses to start when the motor is hot.

quick fix-
locate the starter motor, usually located beneath the radiator, after running for 5-10 kms, check whether it is hot & pour water to cool it and start the engine. if the engine cranks the starter motor brushes have gone for a toss. replacing them would set u back by 1000 bucks
 
Joined
Jul 4, 2011
Messages
255
Likes
30
Location
Sydney
seems the problem is with the starter motor. i had the same problem with my ikon. the car refuses to start when the motor is hot.

quick fix-
locate the starter motor, usually located beneath the radiator, after running for 5-10 kms, check whether it is hot & pour water to cool it and start the engine. if the engine cranks the starter motor brushes have gone for a toss. replacing them would set u back by 1000 bucks
This. Im surprised no one actually mentioned this till now.
On another note, is your car blowing any sort of white smoke when driving?
 
Thread Starter #11
Joined
Jul 4, 2011
Messages
9
Likes
0
Location
Delhi
sorry i have been away,thanks for your suggestion,will look into starter issue and comment, car is not blowing any white smoke, it runs just fine throughout , but if it stops and time is bad , it wont start till given 20-30 min, one of my friend through whom i purchased says,it is just that if u run it on cng and put ac on,it gives load on the engine ,since the engine is overhauled and is not settled ,it gives that issue so he adviced me to run it on petrol for 1000+kms and if running on cng, dont switch the ac on, not sure if that makes any sense,i m diving 15-20 kms for past couple of days and have not faced the issue so far as i m not driving continuously, in a hot day,will drive again to see if the problem persists, the starter issue makes sense and will get that addressed, many thanks, pl also advice if running on cng with ac is ok or should i avoid it,thanks
 
Joined
Jul 6, 2011
Messages
191
Likes
3
Location
Rajahmundry
if the car is still in the running in period better to drive on petrol, for atleast 1000kms running the car on cng makes the engine dry . whereas petrol lubricates it.
 
Thread Starter #14
Joined
Jul 4, 2011
Messages
9
Likes
0
Location
Delhi
thanks for ur advice again,55k is early for the engine overhaul however i spoke to the pre owner who said it had to be overhauled as he had hit sharp a stone on the bottom and the engine parts were affected,the maruti engine had suggested to get it overhauled,
 
Joined
Jul 4, 2011
Messages
255
Likes
30
Location
Sydney
thanks for ur advice again,55k is early for the engine overhaul however i spoke to the pre owner who said it had to be overhauled as he had hit sharp a stone on the bottom and the engine parts were affected,the maruti engine had suggested to get it overhauled,
Previous owner hit a sharp stone at the bottom: Most probably he cracked open the oil sump, which would have lead to a the engine running dry (no oil) and running an engine without any oil even for a short distance is a very bad choice.
not to scar you, but just ask the owner about the over haul process, about what all work was done to it.

If it is missing any of the following, I would suggest you get them done at a later time.

  • new head+gasket
  • conrods [this will be the main cause of any major damage, I've had some experience]

back on topic, if the car is running fine on petrol without the starter motor being replaced. Then I suggest you take the car back to where you got the LPG fitted and ask to them re-tune your car. won't be more than a couple of hundred rupees for a CNG re-tune.

I hope it helps.
 
Top Bottom