Maruti Suzuki Wagon-R: Technical Queries & Solutions


Joined
Dec 16, 2019
Messages
1
Likes
0
Location
Hyderabad
I have a 2008 WagonR that has run 48000 km. There is a clatter noise from the engine on slight acceleration which is present only during running. But at the same time when I depress the clutch and accelerate the sound is not present. MASS isn’t able to identify the source. Will Throttle body and injector cleaning solve the problem? The Mileage and performance of the car is not affected. I have used IFTEX system G since past 500kms and the clatter has reduced to some extent but is still present.
 
Last edited:
Joined
Dec 29, 2019
Messages
1
Likes
0
Location
Delhi
Dear seniors.
I have wagon r , four year old , in a very new condition. It had hardly cover 30000km. Today i went to maruti service centre for my fouth service. But out my shock they had made bill of ₹11085.
I am attaching complete bill. Please have a look. Plus they also had a scheme of free wheel alignment and rubbing polishing. With all that it cost me so much. Please tell me if there's anything which i shouldn't have opted.
 

Attachments

Joined
Jan 16, 2016
Messages
10,487
Likes
4,230
Location
Payyanur/Kannur
Have you taken any warranty schemes other than the Original warranty comes from Maruti?

The bill seems inflated. Did they inform you before doing all these works and got your authorisation?

It seems you have already paid the bill. You should have objected and asked for details/clarification. If needed, you should have photographed the bill and sent to Maruti for clarification. Even if you have paid the amount and took delivery of the car, still you can lodge a protest with Maruti customer care along with the bill.

Let's see what others have to say ?
 
Joined
Aug 10, 2018
Messages
5
Likes
0
Location
Delhi
Hi guys,

Hope you are doing well.

I have a very mysterious issue with my wagon r2014 petrol.

It's returning a mileage of 9/10kmpl since the past 2 years.
I went to MASS and what they suggested is the fuel sensor is choked so fuel body needed to be cleaned. They dismantled all injectors , carburettor, and other stuff and cleaning everything. No difference in fuel economy.

They checked the OB sensor but no error was reflected on their laptop

Went to another guy. He said clutch issues. Went with clutch plate replacement with pressure plate changed too. Nothing happend
Done this twice

Still it's returning a mileage of 10kmpl

No one is able to diagnose the issue

Please help

Thanks in advance
 
Joined
Aug 12, 2013
Messages
86
Likes
17
Location
MUMBAI
Hi guys,

Hope you are doing well.

I have a very mysterious issue with my wagon r2014 petrol.

It's returning a mileage of 9/10kmpl since the past 2 years.
I went to MASS and what they suggested is the fuel sensor is choked so fuel body needed to be cleaned. They dismantled all injectors , carburettor, and other stuff and cleaning everything. No difference in fuel economy.

They checked the OB sensor but no error was reflected on their laptop

Went to another guy. He said clutch issues. Went with clutch plate replacement with pressure plate changed too. Nothing happend
Done this twice

Still it's returning a mileage of 10kmpl

No one is able to diagnose the issue

Please help

Thanks in advance
what is the colour of exhaust gas? Black or White ?
Does exhaust pipe shows water dropping in the morning ??
 
Top Bottom