Maruti Suzuki SX4 Diesel: Sluggish Acceleration


Thread Starter #1
Joined
Oct 16, 2011
Messages
354
Likes
237
Location
kasargod/mangalore
i got a strange problem in my sx4 zdi.

Details:
march 2011 model
done 10500km

Every time after initial driving of around 35km,car feels very sluggish,does not accelerate freely,rpm wont cross above 1500. This problem gets solved if i restart the car.i encountered this problem around 5 times till now.I mailed maruti suzuki regarding this,they immediately sent 2 service engineers from Cochin to check our car.Really Maruti Suzuki deserves 1st place in after sales department.

Sx4 zdi is OBD 2 complaint.So they did OBD2 diagnosis,took them with me and went for a drive.I could show them the problem.OBD could diagnose fall in blow pressure(am not sure,i forgot what he actually said).Service engineer advised to replace turbo hose and fuel pump which will arrive at the dealership by next week.hope all will be fine[:)]

Received: 11/28/2011 8:16 PM
To: ATM Queue
Subject: SX4 DIESEL: SUDDEN DROP IN PICK UP

Sir,

I own march 2011 sx4 zdi model.i have noticed sudden drop in pick up
of my car around 5 times,it gets solved by restarting the engine.The
acceleration is so much reduced,no response even on pushing full
accelerator,but it gets fine after turbo kicks in or by re staring the
engine.i have completed 10,000km.So will be going to the dealer for
3rd free service.I read a post by sx4 diesel owner in facebook about
drop in pick up and dealer told its because of some defective hose
pipe.So changing this hose pipe will solve my problem too?



Dear Mr. konamme,
We are in receipt of your e-mail dated 29.11.2011 regarding your Maruti SX4 Zdi. We regret for the inconvenience caused to you in this regard.

We are advising our Regional Service Manager posted at Regional Office COCHIN (0484-4088400) to look into the matter and extend necessary assistance.

In the meantime, we would request you to kindly bear with us.

In future correspondences, please quote the above subject reference number.

Assuring you of our best services always.

Thanking you,

Yours Sincerely,

Kenny John Mathew
(Manager, Service - 3)
Maruti Suzuki India Ltd
CC : RSM - S3, MSIL Workshop
 
Last edited:

350Z

Core Team
Joined
Aug 10, 2009
Messages
18,425
Likes
6,190
Location
New Delhi
Good to see Maruti still listening to the customers. Best part is that your car is presently under the warranty. Do update us after the replacement has been done.

Drive Safe,
350Z
 

vijay

Moderator
Joined
Aug 23, 2009
Messages
3,158
Likes
822
Location
Ahmedabad
I have a case where new swift zdi was replaced by maruti after complains of car stalled on couple of occassions.AFter much discussions and all, maruti did accept the issue and provided with new car to the owner.Its a great thing to have done from manufacturer.
Hope maruti continues to serves the same way.Keep updating your thread and sorry to bump in your thread but thought to share.
 
Joined
Aug 9, 2011
Messages
1,994
Likes
344
Location
Noida
The 1st thing that comes to mind is a leaking turbo or issues with the BOV. But wait, you said the issue shows up after driving some 35Km, so , we can rule out the turbo and BOV. That said, please take your car to MASS again and have a ECU scan done. Most likely, the predefined map has lost it's values. Try the ITALIAN tune-up : Find an empty road and try nearing redlining in almost all gears. Then slow down a bit to say around 40-50 kmph in 4th gear and down shift to 3rd and then again redline. If this helps, then wash the ECU data by disconnecting the battery for 20-30 mins and then drive normally how you daily do. ECU will learn your driving pattern. Also, get the filters cleaned.

freakdude.
 
Thread Starter #5
Joined
Oct 16, 2011
Messages
354
Likes
237
Location
kasargod/mangalore
Maruti Suzuki is going to send their senior engineers to check our car soon.ECU scan is already done(OBD 2 diagnosis).Dealer said if problem doesnt get solved here,the car will be taken to manesar plant[frustration]
 
Joined
Dec 1, 2011
Messages
42
Likes
1
Location
Mumbai
I would say that Maruti has really given a good after sales service unlike some of other manufacturers who do not accept that their vehicles can be defective just to save a few pennies. After all the car has already been sold, money has been realised and more money to be realised when the car comes to the service center. For these manufacturers the car cannot have ANY defect till the warranty expires and immediately after the warranty period is over, they discover a range of parts to be replaced. During the warranty period, it is your faulty driving, bad roads, wrong storage, adulterated fuel and what not who are the culprits. Anyone & Anything but them.

Well done Maruti!
 
Thread Starter #7
Joined
Oct 16, 2011
Messages
354
Likes
237
Location
kasargod/mangalore
Maruti Suzuki sent their team from regional office to the dealer today.They will do a full check on car,all sensors will be checked.Fuel pump may be the culprit,but still not very sure.may get back the car tomorrow if it gets proper else it will be sent to manesar[confused]
 
Joined
Aug 2, 2011
Messages
2,765
Likes
437
Location
Pune
Good to see that maruti acting positively, mean which do ask them for replacement car for time being to use till your car comes back.
 
Thread Starter #9
Joined
Oct 16, 2011
Messages
354
Likes
237
Location
kasargod/mangalore
finally problem solved[:)] fuel pump relay was changed under warranty,did around 150km road test with maruti guys,no problems!!!
Also got 3rd free service done,costed 3450rs.oil filter,engine oil was changed.mobil 3000 formula 1 5w 40 oil was used
 
Joined
Oct 23, 2009
Messages
9,165
Likes
329
Location
Chennai
Well that's great to hear , this is why still Maruti is the leader when it comes to A.S.S.


Mods can something like problem solved now be added to the thread title? Will be very useful for those who are searching the net because of the same problem.
 
Thread Starter #12
Joined
Oct 16, 2011
Messages
354
Likes
237
Location
kasargod/mangalore
Same problem appeared again after running around 800kms,mailed about this again to maruti suzuki,their team came to our dealer and checked all codes,did obd 2,finally finally problem is solved,it was due to error/change in fuel injection code,but even suzuki engineers are not sure how its changed,sabotage by the workers?have run more than 1700kms without any complaint.hope its solved finally
 
Thread Starter #13
Joined
Oct 16, 2011
Messages
354
Likes
237
Location
kasargod/mangalore
Completed 40000 kms in 28 months
Engine management light is back again. Whenever i accelerate in 4th gear and speedometer hits 100,SVS light flashes,and drop in acceleration,car wont accelerate above 3000rpm. The problem resolves after restarting the engine.
Guys..any suggestion?what would be the culprit?
 
Thread Starter #15
Joined
Oct 16, 2011
Messages
354
Likes
237
Location
kasargod/mangalore
Fuel filter is changed during 20k service,40 k service yet to be done.
On OBD diagnosis,it showed turbo boost pressure high(wastegate solenoid malfunction). It was changed under warranty. But same problem has reappeared again
 
Top Bottom