Maruti Suzuki Brezza VDi AMT: Ownership Review


Joined
Nov 19, 2014
Messages
1,862
Likes
986
Location
Trivandrum , Sydney
OP said service center changed viscosity of oil from what to what?
I also have the same query .
When I gave my VVT Swift 1.2 ZXI reborn , from Mobil0W20 they had changed to ECSTAR0W20 (Came to know that ECSTAR is like a franchise of suzuki , and they use Idimitzu oil - Which I am quite proud to have used in my Activa too ) .
 
Thread Starter #50

allhyundaicars

Honoured Member
Joined
Apr 21, 2012
Messages
7,616
Likes
3,273
Location
New Delhi
Mileage update.
I drive 25kms one side daily in less than regular delhi's traffic. Yet this car is giving me just 17.5 kmpl without AC. my figo's 1.5 return 17kmpl in regular Delhi traffic with lots of short trips.

I guess AMT is to be blamed yet the brochure says AMT and manual mileage figures are the same as per ARAI. on this route any diesel car should give 20kmpl since 10kms of the 25kmpl is devoid of any traffic.

In regular traffic with ac this car returns between 14-15kmpl.
 
Thread Starter #52

allhyundaicars

Honoured Member
Joined
Apr 21, 2012
Messages
7,616
Likes
3,273
Location
New Delhi
Got coozo mats for the car. Wasn't really planning to buy but it looked good. Got it for 2500rs. Online rates are above 4k.

IMG_20200228_183033.jpg

IMG_20200228_183027.jpg

IMG_20200228_183022.jpg


Car nearing 21500kms.
IMG_20200228_183039.jpg


1.3L engine needs to power pretty heavy weight , swift ddis we have gives 185kmpl when hard revved and 23-25 under sedate driving.
I think even manual brezza will give at least 22 kmpl on the roads I drive.
 
Thread Starter #54

allhyundaicars

Honoured Member
Joined
Apr 21, 2012
Messages
7,616
Likes
3,273
Location
New Delhi
Car nearing 23k kms. No rattling so far of any kind.
IMG_20200504_195620.jpg


An issue has cropped up with the rear parking sensors. When I put the car in reverse for the first time it shows "clean sensor" , however it doesn't turn up on the second try. Weird. I have checked for dirt or anything stuck but the area around the sensor is clean.
IMG_20200504_195616.jpg
 
Top Bottom