Maruti Suzuki Baleno Hatchback: Technical Issues & Solutions


Joined
Oct 18, 2019
Messages
72
Likes
6
Location
Ranchi
OK Sir. I forgot to tell you that there is no issue with the tire, some thing has cut it little bit and it will not be a problem. Asked me to visit after 6 months to show me that whatever they are telling is right.
Are you sure if no pipe so sound?.
Sir no pipe like sound bit "KHAR KHAR" type sound.
 
Joined
Aug 18, 2015
Messages
1,090
Likes
694
Location
Bangalore
OK Sir. I forgot to tell you that there is no issue with the tire, some thing has cut it little bit and it will not be a problem. Asked me to visit after 6 months to show me that whatever they are telling is right.
Sir no pipe like sound bit "KHAR KHAR" type sound.
Shake the old pipe and see the sound coming from it. Check any valve in it after tearing it.
 
Joined
Oct 18, 2019
Messages
72
Likes
6
Location
Ranchi
Sir, no sound from it & I can not tear it as it may be placed again as the sound is not from this part. Sorry for delayed reply as I was on a long trip from Ranchi to Shantiniketan. I could check the brake on road and its perfect.
 
Joined
Oct 18, 2019
Messages
72
Likes
6
Location
Ranchi
Surya Sir, brakes are OK now, I am cruising above 120 Km/h with confidence.
Sir can please say something about the noise, it is still there even after changing the brake vaccum hose.
 
Joined
Aug 18, 2015
Messages
1,090
Likes
694
Location
Bangalore
Surya Sir, brakes are OK now, I am cruising above 120 Km/h with confidence.
Sir can please say something about the noise, it is still there even after changing the brake vaccum hose.
Yah , we will work on it. Give me some time. How about car leaning to a side and any vibration above 80 kmph.
 
Joined
Oct 18, 2019
Messages
72
Likes
6
Location
Ranchi
No Sir it is not leaning to any side & no vibration too. Even while hard braking just ABS are making noise (Kit Kit ), which is normal as per ASS. But the brake & mileage issues are same as they were earlier.
 
Joined
Aug 18, 2015
Messages
1,090
Likes
694
Location
Bangalore
No Sir it is not leaning to any side & no vibration too. Even while hard braking just ABS are making noise (Kit Kit ), which is normal as per ASS. But the brake & mileage issues are same as they were earlier.
Do not do Alignment and balancing for next 20000 to 30000 km it is set now, or until any issue comes. Mileage on mid is not reliable. Try full tank to full tank method. Can you share the video of suspected noise. You said brake issue gone?
 
Joined
Oct 18, 2019
Messages
72
Likes
6
Location
Ranchi
I will not go for alignment & balancing as par you suggestion. The skidding issue has gone but the abnormal noise is still there. Please let me know how to upload the video, PM ?
Apart from it Wish You & family Very Happy & Prosperous NEW YEAR.
regards,
 
Joined
Jan 21, 2016
Messages
7
Likes
9
Location
Mumbai
Happy New Year everyone!!!!

I have an almost 4yrs old delta CVT. Recently I am facing below issue.
When I put the car in reverse, it starts beeping even if there is no obstacle behind. the beeps are continuous and in group of three something like "teet - teet - teet -- teet - teet - teet" I am not sure what has happened.
I looked at few videos online, which suggested there might be some muck stuck in the sensors, so I cleaned them with WD40 still the same issue. When I put the car in reverse and touch individual sensors there are no vibrations (some forums / videos suggest that when the sensors are working there should be vibrations in them).
Anyone else faced similar issue?
Is there any setting in the car, which might have been reset, and I can change the setting so that they are back to normal? or they have gone kaput!!
Requesting your help.
 
Joined
Jan 21, 2020
Messages
1
Likes
0
Location
New Delhi
I bought the Baleno Delta recently on 22 Dec and i guess the manufacturing date might be 3 month s back because i didnt received the RC yet. Since the Day 1 i heard a sound coming from the Gearbox which can be heard more while the car in the gear and on 2 and 3 rd gear as soon as i release the acceleration it went away in 3rd gear it can be heard fully. This happen when the car runs for approx 5-10 KM.

I report it to the Nexa SC and they agree to change the Clutch Bearing Release & Input Shaft in the 1st service 1000KM day before yesterday. But i can still hear that the problem is still persist and feels that it will start coming as usual in 2-3 days.
Changing gear is also my concern specifically 1st & 2nd Gear Stuck 5 out of 10 times.

Anyone please help what can i do.
 
Last edited:
Joined
Nov 12, 2015
Messages
7
Likes
0
Location
Pune
Dear All,
Please give the solution for Baleno Alpha car petrol
Keyless unlocking/locking using the
door request switches is not working but by remote doors are working.
 
Last edited:
Top Bottom