Hyundai i10 1.2 Starting Problem.


Thread Starter #1
Joined
Apr 5, 2012
Messages
10
Likes
0
Location
Srinagar
Help needed.
My 2009 Hyundai i10 Magna 1.2 has done 22,000 kms. From past 6k kms i occasionally face strange starting problem.
Even on the cold mornings car starts well. I face starting problem after the car has been driven around for a while & as i switch off engine for a while and then try to start again i does not start. There is usual cranking noise. The car may start once a while but dies within a second. The car usually starts again after waiting for few seconds and trying to floor accelerator while cranking the engine. This problem happens once or twice a month. I did take car to Hyundai a.s.s but they did not understand my problem, and car worked fine in their presence.
Can anyone help me to diagnose the problem??
 
Joined
Jul 18, 2011
Messages
1,973
Likes
324
Location
Melbourne
check cold startup injector, most probably they get the problems. (Long startups)

Sticky injectors can do that too.(pumping too much petrol)

Well try putting 98 octane fuel and injector cleaner once every month .

clean maf
Clean Afm
if needed clean throttle body

I assume nothing is wrng with the startup motor
 
Joined
Jul 15, 2010
Messages
811
Likes
84
Location
Pune
Replace the spark plugs. Their quality is on lower side. Try that and let me know if still the problem persist
 
Joined
Jul 18, 2011
Messages
1,973
Likes
324
Location
Melbourne
Replace the spark plugs. Their quality is on lower side. Try that and let me know if still the problem persist
oh yeah I completely forgot about that , thinking it was already aftermarket ones.

my bad.

Get NGK spark plugs they are good.
am running ngk iridium ones
 
Thread Starter #5
Joined
Apr 5, 2012
Messages
10
Likes
0
Location
Srinagar
Thanks for replying Codename47 & Amiti.
I had got spark plugs cleaned and air filter changed at 20k kms along with engine oil change at a Local service centre. But still faced occasional warm Stalls.
Morning cold startup has never been a problem, car usually starts on first try.

Will be visiting Hyundai a.s.s soon for injector, maf , afm
& throttle body cleaning. Any idea how much will be charged for the job?
I am still on stock spark plugs, car manual suggests change at 30k kms. Do i really need to change them at 22k. How much does ngk iridium cost? And how is it better than normal stock Bosh Mico ones?
 
Joined
Jul 15, 2010
Messages
811
Likes
84
Location
Pune
Thanks for replying Codename47 & Amiti.
I had got spark plugs cleaned and air filter changed at 20k kms along with engine oil change at a Local service centre. But still faced occasional warm Stalls.
Morning cold startup has never been a problem, car usually starts on first try.

Will be visiting Hyundai a.s.s soon for injector, maf , afm
& throttle body cleaning. Any idea how much will be charged for the job?
I am still on stock spark plugs, car manual suggests change at 30k kms. Do i really need to change them at 22k. How much does ngk iridium cost? And how is it better than normal stock Bosh Mico ones?
You are welcome. Before you do injector..... all that stuff, try changing your petrol bunk and see. If still the problem persists, then go for that kind of stuff.

hyundai's all claims regarding service intervals are FALSE. So you have done the right thing by changing spark plugs at 22k kms.
 
Joined
Jul 18, 2011
Messages
1,973
Likes
324
Location
Melbourne
Your welcome mate

Don't rely on Hyundai Service centres plus the local mechanics.

I showed my car to the local mechanic he knows about all these things but when I told him about my car a bit he was so confused where to start from.

He said " your car I can fix it resetting the ECU "

I was like , which one ? My car got 2 ECU's , one is standard Nissan Ecu and other is Haltech Ecu for all the aftermarket parts such as bigger turbo bigger injectors and boost controller.

He said oh.. then I need to send it to a tuner to fix it .
Minimum I was looking to spend was 500 dollars!

What I did ?
I bought a new pod filter , opened up AFM and cleaned it with carburetor cleaner , opened my throttle body cleaned it , MAF sensor and TPS cleaned them too. after that car runs much better. and no probs with idling or startup


Amiti , for you

Try changing your spark plugs firsts get platinum ones. NGK iridium are the performance ones.They are expensive but they last 100K. Each one costs 20 dollars here means 4 of them 80dollars ~ 4000rs indian or less. you can get some other brands such as Denso ( made by toyota i assuming) they are iridium ones too. or get some bosch platinum ones.

Try using 98 octane petrol for a month ( there is no loss in using them because they give good mileage too)

You can use injector cleaners too.

do you change petrol providers often too ?
let it be only one and see if the prob persists
 
Thread Starter #8
Joined
Apr 5, 2012
Messages
10
Likes
0
Location
Srinagar
Thanks codename47
I am not good enough for all these DIY jobs, will get hyundai a.s.s to do it. Will be taking car to them soon and will let you know what comes up.
I often get my car filled at different pumps.
 
Thread Starter #9
Joined
Apr 5, 2012
Messages
10
Likes
0
Location
Srinagar
I did take my car to Hyundai service centre this morning, Guess what, they said fault located to Engine Immobilizer. I was asked to keep an eye on engine immobilizer light seen on turning key to 'Start' position when car refuses to start.
Stalled my car in afternoon again. This time I noticed immobilizer light was not coming. Tried with other spare key, still light won't come and car won't start.
Tried turning off, removing key, turning to start again without cranking. After some time immobilizer light comes, i turn to start car and it starts in one go.
Now i'm almost sure where the problem is.
Anyone else had such a problem on their vehicle?
What really went wrong with the immobilizer?
 
Thread Starter #10
Joined
Apr 5, 2012
Messages
10
Likes
0
Location
Srinagar
So i went to Hyundai A.S.S today.
As i said earlier fault had been located to the immobilizer. I was asked to bring in both keys along.
They connected 'GScan' OBD tool to the car. Turned ignition to 'start' immobilizer light was coming. Switched on & off few times. Until once immobilizer light did not come, cranked engine and it did not start. OBD codes were checked for immobilizer.
It showed two errors.
1. Immobilizer Key Transponder Error - P1693
2. Immobilizer key mismatch - P1696
Also under current status,
ECU status - Learnt
Key status - Invalid
Smartra3 status - Learnt

The electrician dealing with my car had no clue how to deal with the problem and phoned someone (in Delhi?). Who asked him to email photographs of errors coming. I was asked to come back next time, until they can figure out the problem. He also suggested lock set change as the last resort. New lock set will cost somewhere around 8k.
Regret not taking extended warranty. Car is already 2 years 9 months old.
(Will attach some photos later.)

Anybody having idea about all this?
As this was first batch of i10's having immobilizer. Is this some manufacturing defeat? How could immobilizer go wrong?
Is there any way to disable immobilizer?
 
Joined
Dec 27, 2012
Messages
1
Likes
0
Location
Kol
My I10 Immobilizer light stopped glowing today suddenly. 2009 July model .. mint condition. I had given to service center for a polish and service and the service station is Calcutta (Mominpore) kept it for 2 complete days. Today just after taking delivery within 50m drive the car went off and never came up again. The mechanics tried something with a gadget for half hour and said nothing can be done today as their internet is not working.

I have to go to the shop tomorrow with the other key and hand it over to them and then pray.

I suspect either the Saini Hyundai Service station has altered some working parts with a faulty one as the car was with them for quite long and I have heard such things are common here.

Will post my next experience soon.
 
Joined
Feb 26, 2013
Messages
1
Likes
0
Location
Hyderabad
My New i 10 (only 50 Km done) yesterday evenig when I tried starting, it didnt start but made a very abnormal noice. The vehicle was still in my apartment parking area. When I called up the customer care they directed the call to the road side assistance. They wanted to tow the car to the nearest service centre. I refused. You cant see your new car being towed as in the case of an accident. Isnt it?

Meanwhile, I made a call to the show room where I bought from.They said they will send a person to check it.

Keeping fingers crossed as to what will happen now. It has made me take leave from my office. Dont know why the problem is. Any suggestion please.
 

Akash

Core Team
Joined
Sep 22, 2009
Messages
6,362
Likes
480
Location
NYC
Hi ssubashchan,

Welcome to The Automotive India.

Sorry to know about the trouble faced by you with your new car. Did you check for any wire chews (by the rodents maybe) which may have led to this malfunction?
Further i am not able to get this statement of your,

it didnt start but made a very abnormal noice.
What kind of noise was it? It was similar to cranking noise or what?
 
Joined
Mar 29, 2014
Messages
32
Likes
3
Location
Hyderabad
i10 is famous for engine stalls. Even my neighbour's i10 is famous for it. There will be only three main reasons. They are:
1.) Engine spark plugs(rusted or not proper).
2.) Engine immobiliser.
3.) Type of fuel.
 
Joined
Oct 20, 2014
Messages
1
Likes
0
Location
Una
Hi , i am having i10 1.2L car...today after 20 days i tried to start my car but engine is giving me crank noise thats all...i tried multiple times but no luck..pls suggest..
 
Top Bottom