Hero Maestro: 6300 Kms Ownership Review


Joined
Nov 5, 2015
Messages
1,253
Likes
686
Location
NCR
Update:
About to complete 7500kms. Started facing problems with the gearbox. Sometime strange sound comes. Mileage has also dropped to 25-30kmpl. Front shockers making strange sound(not audible at high speeds) and the headlight dims as soon as indicator or horn is used.[cry] Anybody can help me with all this?
Check and maintain your tyre pressures for avoiding sudden drops in FE. Front shockers in a friend's Activa also make that "Cheen Cheen" sound when doing their work, this sound gradually increases and is heard mostly on bad roads. The service centre guys would be able to solve it, but remember that this problem will come again at a later stage because of the conventional suspension setup. My friend hasn't reported this issue for some time now and has learnt to live with it. Headlight dimming may be because of a weak battery. Does the starter work and horn sound normal?
 
Thread Starter #32
Joined
Sep 12, 2015
Messages
69
Likes
53
Location
Lucknow
Got my ride serviced and this time I am satisfied. I told the work manager that I was not satisfied with their servicing. So he caught hold of one of his good mechanics and told him to do the whole job. The gear box problem was due to insufficient gear oil.Oil changed and problem gone. Engine oil changed. Shockers were lubricated and problem vanished. As for the light dimming feature it still exists. [anger] This problem vanishes as soon as the ride is taken to service centre. As for the horn, it sounds differently when the headlight is on,else it is normal. The buzzer also sounds differently at night. There was some problem with the kick starter too. It became very hard and also wouldn't return back to it's original position after kicking. The cause was identified as a damaged gear which was costing me around 260INR . I told the mechanic to replace it at the next service, so he said ok and somehow managed to resolve the problem. He also told me to replace the accelerator cable at next service. He also cleaned the spark plug. Though I couldn't feel any difference in power let's see the mileage figures. Keeping my fingers crossed[;)]
 
Last edited:
Joined
Oct 15, 2011
Messages
4,962
Likes
4,272
Location
Some Village
regarding your electrical problem, do get distilled Water filled in battery and have it charged. appears like Battery issue.
 
Thread Starter #34
Joined
Sep 12, 2015
Messages
69
Likes
53
Location
Lucknow
As for filling the distilled water I told the mechanic to do so. But he told me that the battery is a dry one! Now what does he mean with a dry one? Batteries do need electrolyte and I don't think that that there would exist a battery without any sort of electrolyte. Anyways mine is a MAINTAINENCE FREE type battery from exide.Does MF battery also needs distilled water?
 
Joined
Oct 15, 2011
Messages
4,962
Likes
4,272
Location
Some Village
oh! I guess you have a gell type SLA Battery. so Water cannot be added casually. these batteries are finicky and sometimes fail without warning.

please check Battery voltage in the morning without starting vehicle, and once after starting.
 
Thread Starter #37
Joined
Sep 12, 2015
Messages
69
Likes
53
Location
Lucknow
Completed 8900kms[clap] . Headlight bulb was fused so got it replaced. The pilot lamp was also fused but it wasn't replaced as it was out of stock. As for the vibration problem (that kicks in when the ride is driven at slower speeds) the mechanic told me to open the clutch and clean it! I'm still not able to make a decision that should I let them open the clutch for cleaning? Need help with this. Experts please comment. Pics coming soon.
 
Thread Starter #39
Joined
Sep 12, 2015
Messages
69
Likes
53
Location
Lucknow
Does opening of clutch requires right preesure and alighnment? I'm asking so because the mechanic didn't told me about these precautions! Yes bhvm. My tyre has many punctures(to be exact, 5 in number. Thanks to construction sites near my friends home) and have replaced the tube. Yes!!! Maestro does not have tubeless tyres(though maestro edge has it) but it offers tube with puncture endurance.
 
Joined
Oct 15, 2011
Messages
4,962
Likes
4,272
Location
Some Village
I guess it's the puncture patches /plugs causing imbalances and wobbling at low speeds. once the momentum picks up, the vibrations go away.

it's better to get the wheels balanced.

BTW, I don't have any idea about clutch.
 
Thread Starter #41
Joined
Sep 12, 2015
Messages
69
Likes
53
Location
Lucknow
The clutch was opened,cleaned and re installed and the shuddering at low speed went away. Pick up was also increased. Air filter was changed. The filter which I was using was a duplicate one. Replaced it with the original one. But a strange sounds has started coming up. Sound similar to what insects like crickets make. Same sound used to come when the local filter was put in. I'm unable to understand the exact cause behind this. Can someone enlighten me???? The new air filter has been replaced at G.M AUTOMOTIVE(A representative of sun motors which is an authorised showroom and workshop of Hero) Also after using the scooter for 200kms the shuddering problem emerged again. The battery was charged but still the light dimming problem exists!!! Could it be a faulty wiring or any sort of short circuit? Enlighten me experts! Meanwhile the scooter has completed 9600kms yesterday and today it stands at 9645kms.
 
Last edited:
Joined
Oct 15, 2011
Messages
4,962
Likes
4,272
Location
Some Village
abhi,

considering the sub optimal Electricals in 2 wheelers, some dimming is inevitable. it's more prone when slowing down for traffic or speed breaker etc (inconvenient when you need it the most). same used to happen in my activa before I upgraded to Led bulbs.
 
Thread Starter #43
Joined
Sep 12, 2015
Messages
69
Likes
53
Location
Lucknow
About to complete 10900 kms. Couldn't update because of my board examinations. Got my ride serviced. Engine oil changed. Nothing major issues faced tuill now. Seems that Hero tunes it's engines for mileage. Pick up till 50 is satisfactory. But after 50 the engine definitely easily pulls up. Feels strained at 85kmph with two passengers. But cross the economy mark and you will notice a significant drop in mileage. It returns around 25-30 km/ltr if driven above 50kmph. Else mileage is satisfactory. I think performance is better if compared to Activa 3G after 50kmph.
 
Thread Starter #44
Joined
Sep 12, 2015
Messages
69
Likes
53
Location
Lucknow
Noticed a unusual thing. The engine oil level drops very quickly. Only after driving about 1000kms the engine oil level is almost near to the lowest mark and there are no leaks. Seems like engine is consuming the oil. A sweet smell also comes from the exhaust. Can anybody tell me the exact problem?
 
Joined
Oct 9, 2012
Messages
1,887
Likes
2,176
Location
Riyadh/Kanpur
Noticed a unusual thing. The engine oil level drops very quickly. Only after driving about 1000kms the engine oil level is almost near to the lowest mark and there are no leaks. Seems like engine is consuming the oil. A sweet smell also comes from the exhaust. Can anybody tell me the exact problem?
Hi, how do you check the oil level? get the scooter on the center stand, on a flat surface, and the engine needs to be cold, preferably stationary overnight, then check the oil level.

Moreover, if the oil gets mixed with engine, you should notice heavy to medium smoke from the exhaust, do let us know.
 
Top Bottom