Help with My Chevy UVA Issues


Thread Starter #1
Joined
Oct 30, 2012
Messages
14
Likes
0
Location
Jaipur
Hi,

I have Chvey UVA LS, 2007 model, done 61000KM and facing following issues, need your guidance so I can ask service guys to check specific things as I have been making multiple rounds of GM service cetner at Jaipur without any resolution. Problems are:-

1) Engine Check light will come on automatically (I cannot reproduce it on will) sometimes if I strart the engine. I can get rid of this light if I stop the engine in 1st gear and do a couple of stop & start in 1st gear itself. Have got this checked multiple times and they say don't worry its fine.

2) I have started hearing strange airplane like noise from front of the car after I cross 40KM mark, even if I put is in neutral while it is running or switch off the engine, noise is still there. I have tried rotating tyres (new Yokohama ones) but it still persists.

3) Even after couple of round of alignments (initially car was pulling to left), though it runs in straight direction, at 100KM steering shakes and vibrate heavily that I can feel vibrations in my body.

4) The noise from engine has increased lately, like some of the diesel engine

I have always done regular service at every 5000KM, recently changed battery, radiator, timing belt and something related to alternator and now really frustrated by all this.

Please suggest what could be the area of problem, it will be really helpful.

PS - in case my post is in incorrect section, request mod to please move it to correct one but please do not delete it as I am looking forward to expert opinion.
 
Joined
Jul 20, 2012
Messages
112
Likes
15
Location
Noida/Chandigarh
Hi Sunit,

Sorry to hear that you are facing issue with Uva. As you have mentioned that you have done something related to the alternator check as to whether the alternator has been fixed and aligned properly. this might be one of the reason who engine noise.

Thanks
Sunil
 
Last edited by a moderator:
Joined
Apr 26, 2012
Messages
1,256
Likes
395
Location
cochin
Is it your problem no 1,2 & 4 were there before the alternator work done. As Sunbaj said it may be due to the alternator/alternator fixing. Problem no 2 may be due to either tire or Disc. How is your disc and tires condition?
 
Joined
Aug 2, 2011
Messages
2,757
Likes
437
Location
Pune
sunit5 Have you visited your authorized service station/s ? What SA suggested you their?
Also try to get your car checked from a good local mechanic tell all your issues and check this thoughts.
 
Thread Starter #5
Joined
Oct 30, 2012
Messages
14
Likes
0
Location
Jaipur
Hi Sunit,

Sorry to hear that you are facing issue with Uva. As you have mentioned that you have done something related to the alternator check as to whether the alternator has been fixed and aligned properly. this might be one of the reason who engine noise.

Thanks
Sunil
No engine noise was not there even after alternator was changed, they changed it as I was getting engine check warning. I didn't get the warning for a month or so but again started getting it. I showed it at GM ASC and they said no issues but again I am getting it, though I have found a workaround - switch off the engine in 1st gear and restart it and do this process couple of time and it goes.

Regarding noise, this is apparent from last one month, again visited GM ASC and this guy told me get a new car, he checked it for bearning as I insisted but said no problem with bearings, did alignment (that to couple of time as car was pulling to left) however I still have noise from the front of car and steering vibrates /shakes wildly at 100 KM.

Is it your problem no 1,2 & 4 were there before the alternator work done. As Sunbaj said it may be due to the alternator/alternator fixing. Problem no 2 may be due to either tire or Disc. How is your disc and tires condition?
Thanks...well tyre are almost new Yokahama A drive (2 brand new & 2 just 1 yr old), I also got the brakes changed last year. So only probable area for noise could be bearing, which I checked at GM ASC in jaipur, though they acknowledged the noise, they didn't provided the solution. I think I have to escalate it to their management.

Also, what is the way to check if wheel bearings are gone ?

sunit5 Have you visited your authorized service station/s ? What SA suggested you their?
Also try to get your car checked from a good local mechanic tell all your issues and check this thoughts.
Thanks surfer, the GM ASC SA are not very helpful, need to escalate now. I did went to a local mechanic and he said issue could be bearings. Now I am not sure from where I should get it replaced locally or GM ASC.
 
Last edited by a moderator:
Top Bottom