Hello


Thread Starter #1
Joined
Jan 10, 2015
Messages
25
Likes
24
Location
Chennai
Hi,
I recently joined this forum. I hope soon I can share a thread in ownership review page.
About me: From Kerala, works in Chennai.
Will share my experience and learning's with my Chevy Beat and M Celerio AGS.
Right now, a bit busy with my new Celerio RTO paper work as my dealer put wrong data in Temp Reg certificate. Will share my ownership/dealer reviews soon.
 

Akash1886

Honoured Member
Joined
Sep 7, 2014
Messages
10,636
Likes
13,170
Location
Delhi-NCR/ Mumbai
Hi,
I recently joined this forum.
Will share my experience and learning's with my Chevy Beat and M Celerio AGS.
Right now, a bit busy with my new Celerio RTO paper work as my dealer put wrong data in Temp Reg certificate.
Hi WF, Nice to have you aboard The Automotive India. Looking forward to your Ownership Reviews dear. Have a pleasant and long stay here. Also do elaborate on the mistake of dealer in your ownership review. It shall help future buyers to be extra alert.

Regards

Akash
 
Thread Starter #4
Joined
Jan 10, 2015
Messages
25
Likes
24
Location
Chennai
Thank you Akash and Vijay.



Hi WF, Nice to have you aboard The Automotive India. Looking forward to your Ownership Reviews dear. Have a pleasant and long stay here. Also do elaborate on the mistake of dealer in your ownership review. It shall help future buyers to be extra alert.

Regards

Akash
Actually the dealer made a small mistake while entering Chassis number. instead of "xx..xx-LE" they put "xx..xx-KE". Yes, so they put Oct as manufacturing month, where actual manufacturing month is Nov. And another mistake - may be a minor one- I got loan from ICICI Chennai, and they put hypothecated to ICICI Cochin. Now they gave me a letter to RTO and corrected form 21 with correct chassis number and manufacturing date and Bank details. I submitted all these to RTO and was waiting for RC. When I checked on MVD web page, I found my reg number, but the manufacturing month is still Oct. I am waiting for my RC hardcopy to verify other details (Chassis number and Hypothecation). I hope I may get help from the dealer to sort out all these issues as it is their mistake. Also working with dealer to update Insurance data( dealer told me that there is no need to update Manufacturing month as Insurance data includes Manufacturing year only, also in Insurance paper the chassis number part does not include Manufacturing codes).
 
Last edited:
Top Bottom