DIY LED DRL (Low Cost and No-Drill Approach)


Thread Starter #16
Joined
Oct 15, 2011
Messages
5,091
Likes
4,440
Location
Some Village
I have ordered "Vetra LED Headlight For Toyota Fortuner" through Flipkart for my Fortuner. It sounds very economical at INR 288 a pair against the 8K INR product available at Toyota, hope the quality is good and it lasts.

Please let me know if anyone has used it in the past
Did you install them? How is the result?

I have tried lots of Cheap DIY products from China, I wish I had invested that in proper DLRs.
Chinese LEDs are not made to operate in extreme conditions that DRLs have to work at, Like Fluctuating Alternator Voltages, High Heat etc.
Thats the issue. These DRLS do not come with Driver circuit nor any heatsink. Two things that are absolutely critical for any LED Chip.

Also, I cant imagine how doofy chinese engineers are.
They design LEDs for 12v. Forgetting that automotive voltages are in the range of 14.2 to 14.4v. A difference of few volts with non-linear LED behavior means that they're being driven over twice their spec power. No doubt they'll burn in quickly.
 
Joined
Sep 7, 2016
Messages
11
Likes
5
Location
NCR
@bhvm
Appreciate your advise on this...

I got 2 (6ïn) LED bar installed on my car. The mechanic connected them directly to battery via a switch (single wire from switch provide power to both).

One of the bar stopped working in just 10 min of use. However, the other was fine and used it for couple of hours across few months. Assuming that particular piece was defective, I replaced it with a new one. Now again, one of them stopped working in less than 10 min

I suspect there is some issue with wiring, seeing your above response
 
Thread Starter #18
Joined
Oct 15, 2011
Messages
5,091
Likes
4,440
Location
Some Village
@bhvm
Appreciate your advise on this...

I got 2 (6ïn) LED bar installed on my car. The mechanic connected them directly to battery via a switch (single wire from switch provide power to both).

One of the bar stopped working in just 10 min of use. However, the other was fine and used it for couple of hours across few months. Assuming that particular piece was defective, I replaced it with a new one. Now again, one of them stopped working in less than 10 min

I suspect there is some issue with wiring, seeing your above response
Can you post pics of your Install?
 
Top Bottom