Alternator Problem in my Ambassador


Thread Starter #1
Joined
Jul 31, 2010
Messages
8
Likes
0
Location
Chidambaram
Dear TAIians,

I am Manivannan Pillai new member of this great community.

Presently I am owning a Ambassador 2000DSZ (2006)model. On april I fitted a new exide battery into my car. After fifteen the battery got discharged and I took it to the dealer. He charged the battery and told me to check the performance of the alternator.

Then I replaced the rectifier unit, but unfortunately the situation was same as it was before replacement of rectifier unit. After few days the exide company service engineer told me to take the car to authorized service centre.

As per his advice, This morning I took my car to MICO service center and the people there told that everything is fine with my car alternator.
Still the output voltage is only 12.5 volts and 11.6 with AC and Headlights on.
Also the battery is not fully charged. The dealer says that the alternator output should be 14 volts.

Kindly help me to get rid of this problem.

Regards

Manivannan Pillai
 
Joined
Jul 31, 2010
Messages
48
Likes
0
Location
Bengaluru
Hi mani ,well the 2000dsz engine is the Isuzu 4FC1 engine.

The voltage what you are getting is perfect. I suggest you check the battery terminals for rust and loose contact ,if all this is fine then i think the dealer is fooling you because the battery is a defected battery and it needs replacement according to exide.

How often do you use the car ,is it regular usage or you use it once in a week.
 
Last edited:
Joined
Sep 6, 2009
Messages
1,025
Likes
20
Location
Pune
Somethings wrong with the new battery.
(If you are driving your car daily or even 5 times a week)

2-3 volts don't make a big difference to recharging processes of a battery.

Check for interior lights or radio,etc staying ON without your notice.
 
Joined
Apr 16, 2010
Messages
64
Likes
0
Location
MH 10
dont know about isuzu engine ambassador but my matador engine ambassador alternator shows 14+ Volts at idle with 88AH exide battery fitted
 
Joined
Aug 24, 2009
Messages
1,055
Likes
15
Location
Bangalore
Following is the Electrical specification for Ambassador 2000DSZ


  • Battery: 12 Volt, 75 Amp. Hour
  • Alternator: 12V , 55A
The EXIDE dealer is definitely trying to fool you and there is nothing wrong with your alternator. I would suggest you to get the battery replaced immediately and report the issue to EXIDE. You can not rule out the possibility of battery being counterfeit / damaged.
 
Last edited:
Thread Starter #7
Joined
Jul 31, 2010
Messages
8
Likes
0
Location
Chidambaram
Dear TAIins,

Greetings

I am delightened to see the tremendous response from all of you with regard to my alternator problem. As you have suggested I will check for the electrical system as well as the battery condition and will get in touch with you soon.

Best regards

Manivannan Pillai
 
Joined
Jul 6, 2010
Messages
2,175
Likes
16
Location
Bangy
Mr Manivannan. You are privileged to be the only Ambassador owner in this forum. I would be nice if you could post some pics of your Amby and write a short review.
 
Thread Starter #10
Joined
Jul 31, 2010
Messages
8
Likes
0
Location
Chidambaram
Thanks to fellow TAIians

Dear TAIians,

Greetings,

Now my alternator output with the engine alive is 14.2, with AC and Head Lights switched on, it gives an output of 13 volts.

Is this normal?!!!!!!!!!!!!

Also yesterday when I was driving my car with AC switched on, the engine stopped suddenly, then on I cranked , It got started immediately. Is this a sign of any problem?

Another thing is that, whenever I crank my car engine in the morning, it struggles and then after two or three attempts it gets started. But I don`t experience this trouble after driving a few km.

I request your valuable suggestions in this regard.

regards

Manivannan Pillai
 
Joined
Aug 24, 2009
Messages
1,055
Likes
15
Location
Bangalore
Now my alternator output with the engine alive is 14.2, with AC and Head Lights switched on, it gives an output of 13 volts.

Also yesterday when I was driving my car with AC switched on, the engine stopped suddenly, then on I cranked , It got started immediately. Is this a sign of any problem?

Another thing is that, whenever I crank my car engine in the morning, it struggles and then after two or three attempts it gets started. But I don`t experience this trouble after driving a few km.
Your alternator out put is normal. But seems like there is some trouble with electrical, at least it is just coming up. Please check the bushes in alternator and alternator in general to make sure that it is in healthy stage. Also do check the battery terminals and related wiring.
 
Joined
Sep 6, 2009
Messages
1,025
Likes
20
Location
Pune
Dear TAIians,

Greetings,

Now my alternator output with the engine alive is 14.2, with AC and Head Lights switched on, it gives an output of 13 volts.

Is this normal?!!!!!!!!!!!!
Normal.

Also yesterday when I was driving my car with AC switched on, the engine stopped suddenly, then on I cranked , It got started immediately. Is this a sign of any problem?
Doesnt sound like a big problem but if it happens again get it check from a mechanic. Can be anything.
Did the engine stop when you switched on the AC while driving ?

Another thing is that, whenever I crank my car engine in the morning, it struggles and then after two or three attempts it gets started. But I don`t experience this trouble after driving a few km.
This can be a battery problem. But generally the old engines wouldn't start in the first crank that too in the morning.
 
Thread Starter #14
Joined
Jul 31, 2010
Messages
8
Likes
0
Location
Chidambaram
Dear Bhujbal,

Thank you very much for your reply.

Actually my car engine stopped while running with the AC on.

One of my friend told that the cold starting trouble may be due to heater plugs. Is it right?

Regards

Manivannan Pillai
 
Joined
Sep 6, 2009
Messages
1,025
Likes
20
Location
Pune
Yes it definitely could be because of the heater plugs/glow plugs. But it again could be normal as the engine is growing old day by day.

No idea why the engine must have stopped suddenly,there can be many reasons.
 
Top Bottom