‘Radiator Thermo Valve’ (RTV). Maruti 800


Thread Starter #1
Joined
Apr 8, 2012
Messages
124
Likes
1
Location
Kandy, Sri Lanka
A ‘Radiator Thermo Valve’ (RTV) is not installed on my Maruti 800 (1996). i'm planning to install one RTV soon.

Could someone show me the location where the RTV is located?
 

Varun560061

Honoured Member
Joined
May 1, 2011
Messages
3,592
Likes
749
Location
Bangalore
Do you need the thermostat valve rite, it is located just next to the hose which connects the radiator, I will try to post the pic..
 
Thread Starter #8
Joined
Apr 8, 2012
Messages
124
Likes
1
Location
Kandy, Sri Lanka
The radiator fan switches on when the temperature gauge is at about 1/4 of the scale. (do not go beyond that position). I feel the gauge is faulty. Can the sensor (close to the thermostat valve) or the gauge on the dash, the culprit???????
 
Joined
Apr 4, 2012
Messages
2,524
Likes
250
Location
Mumbai
There doesn't seem to be anything wrong.

Check the pipes for leaks and keep an eye on the coolant levels.

It would be a good idea to change the radiator cap if you have not recently.They are cheap to replace.

Like Varun said if the gauge doesn't rise after driving for a long time can be more than 20kms sometimes too.Then it can be a faulty gauge.

Also it could be a part called the thermoswitch.

I'd suggest you drive non stop for an hour with sufficient coolant in your radiator and overflow reservoir and see what happens before changing anything.
 

Attachments

Joined
Apr 4, 2012
Messages
2,524
Likes
250
Location
Mumbai
After driving non stop for an hour.The needle should be at a bit less than the half mark.

If this is achieved then everything is working like it should.

If it is going over the half mark,then the cooling system needs to be checked accordingly.
 
Thread Starter #12
Joined
Apr 8, 2012
Messages
124
Likes
1
Location
Kandy, Sri Lanka
The needle reaches 1/3 position after 10 minutes run and remain at 1/3 position even I drive more than 20km.

The radiator fan is on, when the needle at 1/4 position and remains on beyond that point.

Radiator cap is a new one and the radiator fan thermo switch is almost new (Nissan, japan)

Water pump cleaned recently and verified no leak from water pump.

No change in Radiator water level and reservoir water level when I drive non-stop for more than 1 hour.

What I can understand from your comments is that there is nothing wrong with the cooling system now but something wrong with the temperature gauge.

I can easily replace the sensor (small cylindrical part) attached to the wire of the gauge but I'm not sure the gauge on the dash board is available.
 
Thread Starter #14
Joined
Apr 8, 2012
Messages
124
Likes
1
Location
Kandy, Sri Lanka
I fixed a new Water temperature gauge and the needle of temperature gauge is at half way mark now. Problem now solved.

Thank you all for your valuable comments/pictures/etc.
 
Last edited by a moderator:
Top Bottom